Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Schnittstelle finden
#1
ich habe das Gerät DL410 an den neuen Laptop angeschlossen. Im Programm Zellärm wird der Anschluss leider nicht mehr erkannt (bei meinem Vor-Gerät gab es im Zellärm eine Einstellmöglichkeit für die COM-Schnittstelle. Die zeigt das Programm jetzt nicht mehr an).
Wie kann ich die Verbindung herstellen?
 
Reply
#2
Welches Betriebssystem hat Ihr neuer Laptop (z.B. Windows 7/64 bit)?

Laden Sie sich bitte das komplette Zip direkt von der Seite des Entwicklers HJBerndt herunter:
Download-Link Zellärm


Entpacken Sie das Zip-Archiv und starten Zellärm.exe

Das Auswahlfeld für die COM-Schnittstelle finden Sie im letzten Reiter "Einstellungen" ganz rechts oben als "Schnittstelle"

Viele Grüße

Roger
Roger
from the Kainkalabs-Vault
A division of AK Modul-Bus
 
Reply
#3
(08-27-2015, 12:06 PM)Roger@kainkalabs Wrote: Welches Betriebssystem hat Ihr neuer Laptop (z.B. Windows 7/64 bit)?

Laden Sie sich bitte das komplette Zip direkt von der Seite des Entwicklers HJBerndt herunter:
Download-Link Zellärm


Entpacken Sie das Zip-Archiv und starten Zellärm.exe

Das Auswahlfeld für die COM-Schnittstelle finden Sie im letzten Reiter "Einstellungen" ganz rechts oben als "Schnittstelle"

Viele Grüße

Roger
Hallo Herr Kainka,
ich habe Win7/64 bit.
Seit dem Umstieg auf den Laptop wird die "Schnittstelle" nicht mehr angezeigt, siehe Anhang.
Das Zelllärm-Programm habe ich neu heruntergeladen, das Schnittstellen-Fenster zeigt sich nach wie vor nicht.
Freundlicher Gruß
B.K.


Attached Files Thumbnail(s)
   
 
Reply
#4
In dem Screenshot fehlt tatsächlich die Einstellmöglichkeit für die Schnittstelle. Auf jeden Fall muss das Programm als Administrator gestartet werden, damit Windows die Schnittstelle zulässt. Vielleicht klappt es dann.
 
Reply
#5
(08-27-2015, 02:20 PM)Bebel_16 Wrote: ich habe Win7/64 bit.
Seit dem Umstieg auf den Laptop wird die "Schnittstelle" nicht mehr angezeigt, siehe Anhang.
Das Zelllärm-Programm habe ich neu heruntergeladen, das Schnittstellen-Fenster zeigt sich nach wie vor nicht.

Sehr merkwürdig...
Bei mir sieht es auf 2 verschiedenen Win7/64bit-Rechnern so (korrekt) aus, wie in der Anlage.
U.a. auch auf meinem Laptop ohne serielle Schnittstelle.

Bei den meisten "alten" Programmen (vor Windows Vista,7,8,8.1,10) sollten Sie ab Windows Vista folgende Punkte beachten:

1.) In einem Administrator-Konto angemeldet sein!

2.a) Programm als Administrator ausführen (Programm nicht direkt per Doppelklick starten, sondern mit Rechtsklick "Als Administrator starten")

2.b) Alternative dazu: 
Verknüpfung zum Programm anlegen --> rechte Maustaste "Eigenschaften" --> Reiter "Verknüpfung" --> Schaltfläche "Erweitert" --> Häkchen bei "Als Administrator ausführen" setzen

3.) In manchen Fällen muß mindestens ein Drucker installiert sein!


Punkt 1.) und 3.) sind bei meinen Testsystemen immer erfüllt.
Punkt 2.) war bei mir nicht notwendig, kann aber je nach Sicherheits-Einstellungen erforderlich sein.

Ansonsten ist es mir ein Rätsel, warum es nicht laufen sollte.

Der letzte Ausweg ist immer noch der "Kompatibilitäts-Modus" für Windows XP oder ältere Windows-Versionen:
--> Wie bei Punkt 2.b) vorgehen und im Reiter "Kompatibilität" das Häkchen bei "Programm im Kompatibilitätsmodus ausführen für...", die entsprechende Version auswählen und ggf. noch das Häkchen bei "Als Administrator ausführen" setzen.

Geben Sie bitte Rückmeldung, ob und welche Maßnahme zum Erfolg geführt hat.

Viele Grüße

Roger


Attached Files Thumbnail(s)
   
Roger
from the Kainkalabs-Vault
A division of AK Modul-Bus
 
Reply
#6
(08-30-2015, 12:09 AM)Roger@kainkalabs Wrote: Geben Sie bitte Rückmeldung, ob und welche Maßnahme zum Erfolg geführt hat.

Viele Grüße

Roger

Hallo Roger,
danke für die Tipps. Ich habe sie ausgeführt, leider immer noch kein Kontakt zum Gerät.
Ich habe die DL410 über einen Adapter (Serial to USB) angeschlossen. Er wird auch als funktionierend angezeigt.
Kann ich die Schnittstelle (welche ist richtig?) auch per Hand einstellen? Siehe Anhang
Freundlicher Gruß
Bernd


Attached Files Thumbnail(s)
   
 
Reply
#7
(09-01-2015, 08:29 AM)Bebel_16 Wrote: Ich habe die DL410 über einen Adapter (Serial to USB) angeschlossen. Er wird auch als funktionierend angezeigt.
Kann ich die Schnittstelle (welche ist richtig?) auch per Hand einstellen? Siehe Anhang

Ah. Das könnte das Problem sein.
Viele unser Produkte mit serieller Schnittstelle funktionieren nur mit einem "echten" (vollbelegten) USB-Seriell-Wandler.
Die "einfacheren" Typen (wie möglicher der verwendete Adapter mit Prolific-Chip) bilden oft nur die RxD und TxD-Leitung nach.
Wir empfehlen deswegen für unsere Produkte nur Adapter mit FTDI-Chip wie z.B. unseren ADAPUSBCOM.
Außerdem sprechen manche unser Programme die Funktionen des Chips direkt an, was ebenfalls nur mit den USB-Seriell-Wandlern mit FTDI-Chip funktioniert.

Ich muß mal nachsehen, ob das beim DL410 eine Rolle spielt.
Der Verdacht liegt aber nahe.

Die COM-Schnittstellen-Nummer kann man natürlich wie in dem Screenshot dargestellt selbst umstellen.
(Muß man manchmal sogar, wenn der Chip eine viel zu hohe Schnittstellen-Nummer zugewiesen bekommt)

Viele Grüße

Roger
Roger
from the Kainkalabs-Vault
A division of AK Modul-Bus
 
Reply
#8
(09-01-2015, 11:30 AM)Roger@kainkalabs Wrote:
(09-01-2015, 08:29 AM)Bebel_16 Wrote: Ich habe die DL410 über einen Adapter (Serial to USB) angeschlossen. Er wird auch als funktionierend angezeigt.
Kann ich die Schnittstelle (welche ist richtig?) auch per Hand einstellen? Siehe Anhang

Ah. Das könnte das Problem sein.
Viele unser Produkte mit serieller Schnittstelle funktionieren nur mit einem "echten" (vollbelegten) USB-Seriell-Wandler.
Die "einfacheren" Typen (wie möglicher der verwendete Adapter mit Prolific-Chip) bilden oft nur die RxD und TxD-Leitung nach.
Wir empfehlen deswegen für unsere Produkte nur Adapter mit FTDI-Chip wie z.B. unseren ADAPUSBCOM.
Außerdem sprechen manche unser Programme die Funktionen des Chips direkt an, was ebenfalls nur mit den USB-Seriell-Wandlern mit FTDI-Chip funktioniert.

Ich muß mal nachsehen, ob das beim DL410 eine Rolle spielt.
Der Verdacht liegt aber nahe.

Die COM-Schnittstellen-Nummer kann man natürlich wie in dem Screenshot dargestellt selbst umstellen.
(Muß man manchmal sogar, wenn der Chip eine viel zu hohe Schnittstellen-Nummer zugewiesen bekommt)

Viele Grüße

Roger

Hallo Roger,
ich habe diesen Adapter. Mit dem früheren Computer lief das Programm damit korrekt
Seltsam ...

Kann ich denn manuell die Schnittstellennummer zuweisen? (und wie sehe ich,an welcher Schnittstelle das Gerät liegt?

Freundlicher Gruß
Bernd
 
Reply
#9
(09-01-2015, 05:12 PM)Bebel_16 Wrote: ich habe diesen Adapter. Mit dem früheren Computer lief das Programm damit korrekt

OK. Am USB-Seriell-Wandler liegt es erstmal nicht.

Ich würde vorschlagen, daß Du mal einem anderen Computer mit Win7/64bit das ZIP-File mit dem Programm frisch runterlädts, entpackst und die EXE startest.

Bei uns läuft das Programm wie gesagt ohne irgendwelche Tricks (wie z.B. "als Administrator ausführen") direkt und zeigt sogar mit deaktivierter serieller Schnittstelle (!) das korrekte Bild wie in meinem Screenshot.

Es kann eigentlich nur ein ganz blöder Fehler sein, z.B. daß Du nach dem Runterladen aus Versehen doch die EXE aus dem alten Ordner gestartet hast?

Eventuell hat der Ordner, wo Du das entpackte ZIP-File gespeichert hast, nicht genügend Rechte.
(Eigentlich sehr ungewöhnlich bei einem "Privat-Laptop". Bei Firmen-Laptops kann das schon mal sein, daß die Schreibrechte sehr stark beschränkt werden.)

Mach dazu mal einen Rechtsklick auf den Ordner (nicht die EXE!) --> Eigenschaften --> auf der Registerkarte "Eigenschaften" sollte kein Häkchen bei "Schreibgeschützt" sein.

Dann auf die Registerkarte "Sicherheit" gehen.

Dort sollte am besten "Vollzugriff" eingestellt sein.
Wenn nicht, erlaube den Vollzugriff.

Ansonsten weiß ich auch nicht mehr weiter, da wie gesagt, bei uns alles problemlos läuft.


(09-01-2015, 05:12 PM)Bebel_16 Wrote: Kann ich denn manuell die Schnittstellennummer zuweisen? (und wie sehe ich,an welcher Schnittstelle das Gerät liegt?

Das hast Du Dir doch eigentlich selbst mit Deinem Screenshot beantwortest.
Wenn man im Gerätemanager den Eintrag "Anschlüsse COM und LPT" erweiterst, siehst Du ja direkt den USB-Seriell-Wandler und die ihm zugewiesene COM-Nummer.
Mit Doppelklick auf den USB-Seriell-Wandler --> Registerkarte "Anschlusseinstellungen" --> Schaltfläche "Erweitert" öffnet sich ein neues Fenster, in dem man die COM-Port-Nummer einstellen kann.
(Danach einmal als Benutzer abmelden und wieder anmelden)

Den DL410 sieht man natürlich nicht im Gerätemanager, da sich über die serielle Schnittstelle Geräte nicht selbst dem Rechner gegenüber identifizieren (wie z.B. bei Anschluss eines neuen Gerätes über USB).

Viele Grüße

Roger
Roger
from the Kainkalabs-Vault
A division of AK Modul-Bus
 
Reply
#10
(09-03-2015, 12:59 AM)Roger@kainkalabs Wrote: Ich würde vorschlagen, daß Du mal einem anderen Computer mit Win7/64bit das ZIP-File mit dem Programm frisch runterlädts, entpackst und die EXE startest.
Ja, mit einem anderen Gerät geht es.
Dann werde ich das Programm auf diesem Laptop abhaken unter der Rubrik "Rätsel der Computerwelt".
Danke für dir Unterstützung, Roger,
freundlicher Gruß
Bernd
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)